BuddyBoss Home – Web Support Forums Themes Boss. theme Cant get my comments to load for non-logged in users


Viewing 6 posts - 1 through 6 (of 6 total)
  • Question


    Please have a look at the following post:

    There is no way for comments to display for non-logged in users. (even though you don't have to login for commenting in the settings of the site)

    When they do login, they are presenting with the comments box.

    Then, after submission and approval, the comment appears.

    How can i get non-logged in users to work?

    Any ideas?





    Deepak BuddyBoss

    @johnny the theme should show them to all users. I can see them on your site. Caching issue perhaps?


    Yeah the comment is being shown..

    However, to create a new comment you have to login…

    Is it possible to add a new comment without logging in?

    I have replicated the issue on your demo site:


    If you are not logged in, you cannot leave a comment.

    If this is the case, perhaps, adding a link saying:

    “Please login to leave a comment” would be appropriate.


    Deepak BuddyBoss

    @johnny ah, I see. It appears we have a custom comments.php file. I'll see if the devs will change this to default WordPress file, no reason we should override WordPress options. On line 59 find:
    change to:
    as always copy the file to your child theme and edit there.


    Thanks for checking that out.

    I will wait for the next update.



    Deepak BuddyBoss

    @johnny we can't revert to the default wordpress file but we can remove the if statement to check if a user is logged in.

Viewing 6 posts - 1 through 6 (of 6 total)
  • The question ‘Cant get my comments to load for non-logged in users’ is closed to new replies.