BuddyBoss Home – Web Support Forums Themes Boss. theme Strange Redirect Loop

Tagged: ,

Viewing 13 posts - 1 through 13 (of 13 total)
  • Question

    #59363
    @bryceevans

    I had a user email me about a redirect error. She said that it mostly happened when she was trying to read notifications on the platform.

    When I had a tab open, I came back to it from another (on Chrome) and saw the same error. Unfortunately I don't remember what page I was on or what I had clicked/reloading.

    Screenshot attached.

    Answers

    #59465
    @bryceevans

    I have an update. Today, when I navigated to the “Notifications” section of my profile on the website, I tried to click on a specific notification to redirect me to the photo that was liked.

    That was when I got the redirect loop I'm talking about above. Obviously, this is a huge issue if every time someone tries to reply to comments (etc.) they can't access it and hit this loop issue.

    Please help!

    #59504

    Anonymous
    @

    Hi @bryceevans, Please let me know if you are using any redirect plugin and custom function.

    Regards

    #59550
    @bryceevans

    Hi @pallavi – I'm using the Redirection plugin: https://wordpress.org/plugins/redirection/

    I only have one redirect setup to make any logged-in users navigating to “/” (home) are redirected to our “Stories” (activity) page.

    #59571

    Anonymous
    @

    Hi @bryceevans, Please try to deactivate the plugin and try again and see if you still getting redirection issue.

    Regards

    #59634
    @bryceevans

    Hi @pallavi – I believe it was happening before we had that plugin.

    I deactivated it and it's still occuring.

    #60225
    @bryceevans

    @pallavi – just wondering, is there's an update on this?

    #60439
    @vapvarun

    Hi @bryceevans,

    Please send your login details from our contact page to cross check your issues
    Regards

    #61688
    @bryceevans

    @vapvarun – I sent you my details and now the error_log.

    #61737
    @vapvarun

    Hi @bryceevans
    I have received your error log file, i will update you shortly after analysing it.

    Regards
    Varun Dubey

    #61748
    @vapvarun

    Hi @bryceevans

    I have added following inside child theme functions.php

    
    remove_action( 'bp_template_redirect', 'bp_redirect_canonical', 2 );
    

    to fix this issue at your site, it should not be required.

    your activity links are working fine now
    Regards
    Varun Dubey

    #61750
    @bryceevans

    Hi @vapvarun – thank you so much! I'm so happy to finally have this fixed! ?

    Is it possible that there is a message in the error_log to help with this issue as well? I realize this morning the issue may actually be more with the Wall plugin, rather than the media upload.

    But it's my only other main issue affecting the usability for members: https://www.buddyboss.com/support-forums/topic/some-users-cant-see-any-photosactivityposts/

    #61752
    @vapvarun

    Hi @bryceevans
    We will take care of your media query issue inside media forum, i will close this thread.
    Regards
    Varun Dubey

Viewing 13 posts - 1 through 13 (of 13 total)
  • The question ‘Strange Redirect Loop’ is closed to new replies.