BuddyBoss Home – Web Support Forums Themes Boss. theme php errors related to boss theme

Viewing 15 posts - 1 through 15 (of 16 total)
  • Question

    #45763
    @cheech1981

    Hi all,

    I got a white screen of death today on the domain where I'm using Boss/Social Learner (BusinessWritingTutorials.com). I have temporarily resolved the issue, but it has reoccurred (seemingly on its own) once already, so I'm not sure what's going on or how I can avoid the issue reoccurring in the future.

    I was still able to access wp-admin but nothing on the site (just white screens for everything). My hosting provider restored the wp blog header.php file and the site was restored. Upon looking at my error log, the errors below are turning up. Also, the strangest thing was that, after my hosting provider fixed the issue at around 3pm EST, the issue reoccurred about 3 hours later. I have not made any updates to WordPress or plugins in the past couple days or even changed anything on my hosting account.

    [04-Sep-2015 22:02:26 UTC] PHP Parse error: syntax error, unexpected ‘%' in /home2/scholbb4/public_html/businesswritingtutorials/wp-content/themes/boss/footer.php on line 67

    [04-Sep-2015 17:05:49 America/Denver] PHP Parse error: syntax error, unexpected ‘/' in /home2/scholbb4/public_html/businesswritingtutorials/wp-blog-header.php on line 12

    [04-Sep-2015 17:05:50 America/Denver] PHP Fatal error: require(): Failed opening required ‘/home2/scholbb4/public_html/businesswritingtutorials/wp-blog-header.php' (include_path='.:/usr/php/54/usr/lib64:/usr/php/54/usr/share/pear') in /home2/scholbb4/public_html/businesswritingtutorials/index.php on line 17

    [05-Sep-2015 00:51:11 UTC] PHP Parse error: syntax error, unexpected ‘%' in /home2/scholbb4/public_html/businesswritingtutorials/wp-content/themes/boss/footer.php on line 67

    Just a note: Bluehost mentioned to me that they had been running an update script (I think they mean a script to update everyone's wordpress) but I don't know if that affected me or not because I believe that I was already up to date on my own (I had manually updated to WP 4.3).

    Answers

    #45810

    Deepak BuddyBoss
    Participant
    @deepak

    @cheech1981 this appears to be a PHP error saying the PHP function require was not found and the PHP file was unable to be loaded. Please let us know if you continue to get this error after the next 24 hours has passed. You may want to contact your host as they may be having issues themselves on their end with the update.

    #45826
    @cheech1981

    Just happened again sometime last night or this morning. I can fix the error by restoring the wp blog header core file, but of course, every time it goes down, my users lose access until I happen to realize the error.

    I'll contact my host provider again to see if it's a problem from their end, but the last rep didn't seem to think so. I'm already up to date with WordPress 4.3 and all my plugins are up to date, so any wordpress script update from the hosting end theoretically shouldn't affect me, but maybe it is still somehow.

    Is there any reason that Boss, Buddy Boss, or Social Learner could cause this issue without me making any manual changes to my website or databases? (I'm confident that the issue is not me making changes here, because I haven't changed anything, updated any plugins, etc.–haven't even made changes to my hosting account except for restoring the blog header file). I'm keeping backups as well if you'd like to see the old blog header files.

    #45835
    @cheech1981

    Also, one other possibility is the recent problems with the Boss/Social Learner theme (see my other threads). Varun was able to fix one issue manually, but is Boss coming out with an update to fix the problems caused by the previous Boss update? (one of the problem was that the sidebar disappeared–at least one other user mentioned this in the support forums)

    #45926
    @cheech1981

    A tech from my hosting provider looked into this and found two potential issues that were causing the issue in this OP to reoccur. First, he found that a seemingly extraneous index.php file was causing the error. Since removing it, the error has not occurred in a few days, although now my BuddyPress NoCaptcha Register Box does not seem to show the Robot checkbox, so perhaps that was the problem. I contacted the developer of that plugin just now to see what he thinks, but for now I have disabled that plugin (although that is a great plugin, so I hope it can be fixed).

    The tech also mentioned that the coding in the index.html file (not the php file) seemed poorly written, so he mentioned that it was possible that the coding could cause errors (either related to the issue in the OP or in the future–he wasn't drawing a specific conclusion about specific lines of code, he was just noting that it did not seem cleanly written).

    #45943
    @vapvarun

    Hi @cheech1981, index.html is not used anywhere, please scan your installation with https://wordpress.org/plugins/wordfence/
    Regards

    #45975
    @cheech1981

    Thanks for the idea Varun. I ran the scan and it didn't pick up malware (I also have SiteLock and no messages on that end). However, WordFence did pick up 31 possible errors with modified files. Some of them are BuddyPress files, and some others appear to be theme related. I'm attaching the file if you don't mind taking a look.

    #46024
    @cheech1981

    Also, I have now confirmed that at least part of the problem is theme related. With all of my plugins active, I reverted from Social Learner to Twenty Fifteen theme, and I was able to start quizzes. I also tried with Boss theme, and I cannot start quizzes (so both Boss and Social Learner don't work in terms of starting quizzes).

    My Mark Complete buttons have now completely disappeared (before they were not clickable, but now they are gone altogether). They disappeared during my testing, so I'm not sure what caused this, but I have to say that most of the problems that I have experienced lately have been due to Boss theme. Should I try a fresh install of Boss? I really need my site to be functional–students are emailing me that they can't go through the lessons and quizzes.

    #46029
    @vapvarun

    Hi @cheech1981, let me check your installation today
    Please pm ftp details , i have already your login details.
    Regards
    Varun Dubey

    #46031
    @cheech1981

    Hi Varun, thanks for the response. I'll PM you details in a moment (along with new login details).

    One other thing that I should mention is that somehow I ended up with a plugin called EZ Theme and Plugin Upgrades. I don't remember installing that plugin on my own so I'm wondering if it came as part of BuddyPress or something else that I installed. I see some negative reviews on that plugin's site about it overwriting files with poorly written code, so I'm wondering if that was part of the problem. I have deactivated and uninstalled that plugin.

    #46035
    @vapvarun

    I will check that as well

    #46047
    @cheech1981

    Thanks as always for your support Varun. I pm'd you the logon and ftp details (forgot to post here to let you know).

    #60970
    @toms119

    Hi Varun (and everyone)

    Recently my right sidebar and all widgets disappeared from the home page, blog etc of my site, but are still view-bale on other pages.

    Any fix for this? I called my host about the upgraded PHP they said the widgets wouldnt have worked to begin with if this was the issue.

    Huge fan of the theme, and site I built, hoping I can PM you Varun somehow.

    best,
    Tom

    #61022

    Anonymous
    @

    Hi @toms119, Make sure you have not selected the default page template to full width or send you site details from our contact us page we will inspect the issue.

    Regards

    #61121
    @toms119

    Hi,

    How can I make the non-static front page full width? where are those settings?

    Thank you

Viewing 15 posts - 1 through 15 (of 16 total)
  • The question ‘php errors related to boss theme’ is closed to new replies.