BuddyBoss Home – Web Support Forums Solutions Social Learner Odd lesson behaviour

Viewing 15 posts - 1 through 15 (of 17 total)
  • Question

    #54782
    @familybudgeting

    Hi, I have three issues occurring at the same time. I can't work out what's going on:

    – When viewing a lesson with a Gravity Form in the body content, nothing happens when I click the lesson's “Complete” button.
    – When viewing a lesson, I can't click on a different lesson using the course progress widget. My mouse changes to a finger and the link shows correctly, but when I click nothing happens.
    – Any changes I make to content-single-lesson.php don't appear.

    I turned off the BuddyBoss optimisations, thinking that might be the source of the issues (minified CSS and JS). But no difference. I don't have any other minification or caching plugin active. I've tried disabling all non-essential plugins.

    Originally I had blamed it on the most recent Social Learner update, as that's when I first noticed the problems. I'm not longer so sure, but definitely a bit baffled!

    Cheers,

    Mike

    Answers

    #54796

    Anonymous
    @

    Hi @familybudgeting, Please paste the site url so I can inspect the issue.

    Regards

    #54823
    @familybudgeting
    #56130
    @familybudgeting

    Hi, I didn't receive a response to this question.

    #56205
    @adminchroncleproject-com

    Hi,
    We have this problem too:

    When viewing a lesson, I can’t click on a different lesson using the course progress widget. My mouse changes to a finger and the link shows correctly, but when I click nothing happens.

    I'd be interested to know the solution.

    #56224

    Anonymous
    @

    Hi @familybudgeting, Sorry for the delayed response. I had created a user to test that seems it deleted..so please create a user for me to check it.

    Regards

    #56471
    @familybudgeting

    Hi, login details sent a few days ago.

    @adminchroncleproject-com please do let me know if you find a solution independently. If Pallavi fixes for me I'll be sure to post any results here for you too.

    Cheers,

    Mike

    #56692
    @familybudgeting

    Hi, still waiting for a resolution to this issue: the sidebar widget is the most crucial.

    Cheers,

    Mike

    #56841
    @familybudgeting

    Can I *PLEASE* have an update on this? I really need that widget to be working! @pallavi

    #56877
    @vapvarun

    Hi @familybudgeting,
    I checked but there are lot of instances for prevent trigger. I have reported to developers also to cross check this issue
    At present i have fixed inside your site via adding custom js.

    Regards
    Varun Dubey

    #57334
    @adminchroncleproject-com

    Hi @vapvarun,
    Would it be possible to help us to? Do you need any login info from me?

    Thank you

    #57335
    @vapvarun

    Hi @adminchroncleproject-com, I have already added fix at your site
    Let me know if you are still facing issue

    Regards

    #57340
    @adminchroncleproject-com

    Hi @vapvarun,
    I think you sorted it out for Mike but not for us. Do you prefer if we open a new ticket?

    We have the same problem here: http://oceanschool.wpengine.com/lesson/session-2/
    You must be logged in and join the class to see it. My colleague tell me you already have login info but let me know if you need a new one.

    Thanks

    #57342
    @familybudgeting

    Hi @adminchroncleproject-com, I checked yesterday that Varun's fix works. It does, although I'm not yet sure what the problem was in the first place. This is what he did for us:

    Go to BuddyBoss > Boss Theme > Custom Codes and paste this into the JS box:

    jQuery( document ).ready( function(){
        jQuery(".widget_course_progress a").click(function(){
             window.location = jQuery(this).attr('href');    
        });
    });
    #57343
    @vapvarun

    Hi @adminchroncleproject-com, Please add above codes inside
    BuddyBoss > Boss Theme > Custom Codes and paste this into the JS box
    It will fix the issue
    Regards

Viewing 15 posts - 1 through 15 (of 17 total)
  • The question ‘Odd lesson behaviour’ is closed to new replies.