BuddyBoss Home – Web Support Forums Themes BuddyBoss theme Compatability issue with Visual Composer

Viewing 6 posts - 1 through 6 (of 6 total)
  • Question

    #30815
    @kenkcmarine-com

    Has any one else had issues with Visual Composer not working with background Images / Parallax effects or accordions. When I change the theme back to default wp they work fine so it has be issue problem / error with buddy boss, can you please advice – thanks
    Using the latest updates of all soft wares.

    Answers

    #30825

    Deepak BuddyBoss
    Participant
    @deepak

    @kenkcmarine-com Welcome to the BuddyBoss community! Can you email me a copy of the plugin to @buddyboss.com">tj@buddyboss.com? If I can't figure it out I'll send a copy to our developers for further review.

    #30886
    @kenkcmarine-com

    Just following up with you on the latest information,

    The visual composer developer has revved the issue

    >>>
    We have analyzed your issue and found that there is jQuery conflict with your theme.
    Your theme is de-registering default jQuery library of WP and using its own library that causes to this issue.
    If you notice, revolution slider is also not working due to same issue.
    Kindly contact your theme author to resolve this issue.
    <<<

    So I can understand better why (or how) you are using another library rather than the library of WP?

    #30907

    Deepak BuddyBoss
    Participant
    @deepak

    We are working on this issue.

    #30966
    @michael

    @kenkcmarine-com It seems unlikely that our version of jQuery is causing the conflict, as we're actually enqueuing the same version of jQuery packaged with WordPress now, as of WP 3.9. In the past WP was using an older version of jQuery and we needed the most recent version for some of our functionality (it is backwards compatible). But now that WP is using the modern version of jQuery anyways, we added a condition for the next release so that we default to WP's native jQuery if the site is running WP 3.9 or up, which it will be for anyone who is up to date with their WP.

    #30991
    @michael

    The solution described above is now live. We're now loading jQuery natively, as long as you're running WordPress 3.9 and up. Thanks for alerting us to this issue.

    BuddyBoss Theme 4.0.3 is now available!

Viewing 6 posts - 1 through 6 (of 6 total)
  • The question ‘Compatability issue with Visual Composer’ is closed to new replies.