BuddyBoss Home – Web Support Forums Themes BuddyBoss theme Activity infinite scrolling

Viewing 15 posts - 1 through 15 (of 23 total)
  • Question

    #37566
    @frankwarwick

    Admin option to enable/disable Activity infinite scrolling … where is this located?

    Answers

    #37567
    @interglobalmedia

    Good question Frank. Asked about this myself, but didn't get an answer about disabling yet!

    Best regards,

    Maria

    #37570
    @frankwarwick

    I cant find the location for it and it does not appear to be working for me.
    I am running v4.1.8 multisite with Buddypress and BuddyBoss network activated if that makes any difference

    #37580

    Deepak BuddyBoss
    Participant
    @deepak

    @frankwarwick @interglobalmedia right now the only way to remove it is to remove section 3.7 from js/buddyboss.js we are working on integrating this into the BuddyBoss theme, probably the next minor revision.

    #37581
    @interglobalmedia

    Thanks @tjchester! I can wait.

    #37753
    @michael

    @interglobalmedia @tjchester @frankwarwick

    Actually, if you are using version 4.1.8 (latest release) you can find the option to turn it on or off in the Customizer, under the “Activity” area.

    If this does not work for you, make sure you have not overwritten header.php in your child theme. if you have, copy the line that had changed in header.php.

    <header id="masthead" class="site-header" role="banner">

    to this:

    <header id="masthead" class="site-header" role="banner" data-infinite="<?php echo (esc_attr(get_option('buddyboss_activity_infinite')) !== 'off')?'on':'off'; ?>">

    #37762
    @frankwarwick

    Hi @michael,
    I did have the header.php override in the child theme and have made the change but it made no difference, I am not getting the infinite scrolling. I have been using ‘BP Activity Autoloader' by Brajesh Singh(BuddyDev) which I turned of to test, cleared Cloudflare and the NgenX cache as well as the browser cache
    Also
    When I looked for the controls I can not find them in ‘Appearance/Customize' I don't see anything called “Activity”

    #37766
    @michael

    When I looked for the controls I can not find them in ‘Appearance/Customize’ I don’t see anything called “Activity”

    This is the source of the issue then. If you're running the latest version of BuddyBoss theme (Not Boss) you should have an option in Appearance > Customize > Activity. In Boss theme it is located under Appearance > Customize > Layout Options.

    #37767
    @frankwarwick

    Hi @michael
    no Appearance > Customize > Activity for me
    I am running BuddyBoss 4.1.8
    I have a child theme that I have done a lot of changes to.
    Could I be over writing something somewhere?

    #37768
    @michael

    @frankwarwick It's possible, but not super likely. Did you override the buddyboss-customizer-loader.php file by any chance?

    #37818
    @frankwarwick

    @michael no, I did not override the buddyboss-customizer-loader.php file

    #37842

    Deepak BuddyBoss
    Participant
    @deepak

    @frankwarwick illustration for example where to find it in the customizer to make sure we are all on the same page 🙂

    #37863
    @frankwarwick

    Thanks for the screenshot @tjchester but I am not seeing it on my site

    #37895
    @frankwarwick

    Hi @tjchester and @michael
    With the update released today BuddyBoss 4.1.9 I can now see the tab in customizer
    but there is no infinite scrolling working for me

    #37948

    Deepak BuddyBoss
    Participant
    @deepak

    @frankwarwick it is possible that there is a plugin conflicting with the javascript. Please let me know if this is the case and the plugin conflicting with this code.

Viewing 15 posts - 1 through 15 (of 23 total)
  • The question ‘Activity infinite scrolling’ is closed to new replies.